[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Problems with write protection of "need-look" files and word

From: Fabian Bühler <fabian.buehler_at_ametek.com>
Date: Thu, 6 Feb 2014 05:41:16 -0800 (PST)

Hi
I have troubles working on word files which are locked! Just to give a general understanding of the situation, here some basic information:
I'm using tge collabnet SuberversionEdge server and TortoiseSVN client (1.8.4, Build 24972 - 64 Bit) installed on win7 64Bit! Additional Word 2007. I've set up the project in the repo with the tsvn:autoprops mechanism to set for each *.doc(x) file the svn:needs-lock property automatically! This works just fine so far and locking, unlocking works in connection with other users!
But now I have troubles in connection with word! When I'm working on an already locked file, after some time (or after closing and opening the file again I cannot figure out a rule) word recognizes the file as write protected. Then I have to store that file under a different folder or name. The interesting thing is some changes are already saved! I've checked the file properties, when this happens, but is seems all to be correct, the read only isn't checked.
What I’ve tried so far:
I’ve used a winXP 32Bit computer and here it works fine!
I’ve used a win7 32Bit computer and here it does not work!
I’ve dumped the repo and generated a new database with that dump! The problem still is there.
I’ve set up a new test repo with just the same properties and a word file. Here so far it seems to work!
I’ve moved the project from the server to my computer and accessed it with file based paths. The problem is still there!
Instead of using the TSVN get lock mechanism I’ve unchecked the read only file property by hand. The problem is the same!

So far I have no idea what is going wrong here! For my understanding something between the tsvn, the file system and word goes wrong! But I cannot imagine what! Word seems to check the read only status during opening and storing and cause by something it reacts as the read only is checked!

I would be very happy to get some ideas from you to come closer to understand the problem and find a solution

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3072609

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2014-02-06 14:46:45 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.