[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Bug related to hide/expose events in Repo Browser?

From: David Butcher <dbutcher_at_atre.net>
Date: Tue, 12 Nov 2013 23:13:28 -0800

>From: Stefan Küng [mailto:tortoisesvn_at_gmail.com]
>Sent: Tuesday, November 12, 2013 12:56 PM
>To: users_at_tortoisesvn.tigris.org
>Subject: Re: Bug related to hide/expose events in Repo Browser?
>On 12.11.2013 21:40, David Butcher wrote:
>>> From: Stefan Küng [mailto:tortoisesvn_at_gmail.com]
>>> Sent: Tuesday, November 12, 2013 11:46 AM
>>>> On 12.11.2013 13:03, Michael Geisinger wrote:
>>>> Hi,
>>>>
>>>> Am 12.11.2013 08:34, schrieb David Butcher:
>>>>> I had time this evening to try alternate versions of TortoiseSVN,
>>>>> and also to try turning Aero on an off.
>>>>
>>>> I can confirm that the issue only happens when Aero is turned off.
>>>>
>>>>> 2. Version tests, Aero off, no system changes other than
>>>>> TortoiseSVN version between each test, oldest version first:
>>>>>
>>>>> TortoiseSVN 1.8.0, Build 24401 - 32 Bit , 2013/06/17 18:15:59 -
>>>>> Does not happen
>>>>>
>>>>> TortoiseSVN 1.8.1, Build 24570 - 32 Bit , 2013/07/22 18:28:29 -
>>>>> Happens
>>>>>
>>>>> TortoiseSVN 1.8.99, Build 24945 - 32 Bit -dev, 2013/11/11 20:52:35
>>>>> - Happens
>>>>
>>>> This matches my observations (I also tried the nightly).
>>>> Setting bErase in GetUpdateRect() obviously did not help.
>>>>
>>>> As I said, for me it happens for every window, not just for Trillian.
>>>> But good to know that enabling Aero is a workaround.
>>>>
>>>>> Let me know if there is anything else I can do to assist with
>>>>> troubleshooting this.
>>>>
>>>> Same for me :)
>>>
>>> Try to reproduce this with the log dialog. The bottom list control is
>>> a
>> plain list control, not one that shows a hint text or is
>>> otherwise extended. Does it show the artifacts there too?
>>> If yes, then at least I know where *not* to look...
>>>
>>
>> The trails only show in the first input area in the Log dialog.
>>
>> They do not appear in the middle area, which shows clean log entries,
>> or the bottom area which shows path information.
>
> Thanks for testing.
> I've added another change which might help here in r24949.
> Please try the next nightly build (1.8.99).
>
> I can not reproduce this myself since I currently don't have
> a win7 machine ready, and it's not possible to disable DWM/Aero on Win8
> anymore...

I'm now testing with:

TortoiseSVN 1.8.99, Build 24950 - 32 Bit -dev, 2013/11/12 21:26:31

The first time I launched the Repo-browser the problem seemed to
happen much less frequently. However I closed the Repo-browser, launched
it again, tested again and it now seems to be unchanged from previous
versions. The problem is still there.

The problem also continues to appear in the top pane only of the
Show Log window.

Thanks for your efforts to address this.

David

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3068368

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2013-11-13 08:13:38 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.