[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug related to hide/expose events in Repo Browser?

From: Michael Geisinger <Sidewinder_GER_at_hotmail.com>
Date: Tue, 12 Nov 2013 13:03:53 +0100

Hi,

Am 12.11.2013 08:34, schrieb David Butcher:
> I had time this evening to try alternate versions of TortoiseSVN, and also
> to try turning Aero on an off.

I can confirm that the issue only happens when Aero is turned off.

> 2. Version tests, Aero off, no system changes other than TortoiseSVN version
> between each test, oldest version first:
>
> TortoiseSVN 1.8.0, Build 24401 - 32 Bit , 2013/06/17 18:15:59 - Does not
> happen
>
> TortoiseSVN 1.8.1, Build 24570 - 32 Bit , 2013/07/22 18:28:29 - Happens
>
> TortoiseSVN 1.8.99, Build 24945 - 32 Bit -dev, 2013/11/11 20:52:35 - Happens

This matches my observations (I also tried the nightly).
Setting bErase in GetUpdateRect() obviously did not help.

As I said, for me it happens for every window, not just for Trillian.
But good to know that enabling Aero is a workaround.

> Let me know if there is anything else I can do to assist with
> troubleshooting this.

Same for me :)

> -----Original Message-----
> From: Stefan Küng [mailto:tortoisesvn_at_gmail.com]
> Sent: Monday, November 11, 2013 12:39 PM
> To: users_at_tortoisesvn.tigris.org
> Subject: Re: Bug related to hide/expose events in Repo Browser?
>
> On 11.11.2013 20:35, David Butcher wrote:
>> Hi,
>>
>> A few more bits of information:
>>
>> 1. The Trillian UI allows setting "transparency" in the chat window.
>> The trails only happen when transparency is set to "Visible" - the
>> other settings are 90%, 80% etc. In brief tests, none of those
>> settings leave trails.
>>
>> 2. I can't reproduce the problems (so far) with any other application
>> window moving over the Repo Browser.
>>
>> 3. It's very hard to tell with the mouse moving the window, but it
>> appears that the trails happen more frequently when "X" motion
>> (horizontal) is taking place, rather than "Y" (vertical) motion. That
>> is, moving the window vertically over the repo-browser window leaves
>> fewer trails than moving it horizontally
>>
>>
>> I can't downgrade to 1.8.0 until this weekend due to work deadlines (
>> I use Tortoise constantly).
>>
>> Thanks,
>>
>> David
>>
>> __________________________________
>> David Butcher, Client Services Director www.atre.net land line +1 831
>> 464 0104 | text or mobile +1 831 239 9735 email dbutcher_at_atre.net |
>> fax +1 831 740 3814 __________________________________
>>
>> -----Original Message-----
>> From: Michael Geisinger [mailto:Sidewinder_GER_at_hotmail.com]
>> Sent: Sunday, November 10, 2013 12:58 PM
>> To: users_at_tortoisesvn.tigris.org
>> Subject: Re: Bug related to hide/expose events in Repo Browser?
>>
>> Hi,
>>
>> Am 08.11.2013 03:03, schrieb David Butcher:
>>> Hi, I am seeing strange behavior in the latest Windows 32 bit build.
>>> I think it’s new or only in the most recent few Tortoise builds.
>>
>> I'd thought I'd add some more details on this issue, because I'm
>> experiencing it as well and I can definitely get rid of the "strange
>> behavior" when I downgrade from 1.8.1 to 1.8.0. Find below some more
>> facts.
>>
>> For me, this issue has the following characteristics:
>>
>> - It happens for various list view controls in TSVN, not only in the
>> repo browser. For example, the list view control in the "Show Log"
>> window is affected, but none of the list view controls in the
>> "Settings" dialog, for example.
>>
>> - It happens in conjunction with every Windows application window which
>> I resize or move on top of a list view control in TSVN, not only for
>> Trillian (I haven't verified it with Trillian, though).
>>
>> - It does *not* happen in other programs that use list view controls
>> (e.g., Explorer, applications built for Win9x or NT-based
>> applications).
>>
>> - I have Windows 7 64 bit, so it does not seem to be limited to Vista
>> or 32 bit. I have also an nVIDIA card, but I'm not sure whether that
>> one or my Intel card is used, because my card has Optimus technology.
>>
>> Since I can reproduce this with TSVN 1.8.1 and newer, but not with
>> TSVN 1.8.0, it might be interesting to investigate the following two
>> points:
>>
>> 1. David, can you confirm that this issue is not limited to the repo
>> browser window, but also appears in the top pane of the "Show Log"
>> dialog? Furthermore, can you confirm that this problem is fixed when
>> downgrading to 1.8.0? Notice that after the downgrade, you probably
>> need to run one more "repair install" of 1.8.0 to get TSVN back working.
>>
>> 2. Which changes were done with respect to the list view controls in
>> TSVN 1.8.1, if any? Suspicious commits include r23876 and r24450.
>> Stefan, could it be that the fix for the issue discussed in
>> <http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMess
>> ageId=3011957> leads to the painting to be skipped in the respective
>> cases?
>>
>> I currently did not try to build TSVN myself to check whether the
>> mentioned revisions cause the problem, but I could do it if necessary.
>> Alternatively, I could try a nightly if you are willing to give it a try.
>>
>>
>> Reproducible for me in:
>>
>> TortoiseSVN 1.8.1, Build 24570 - 64 Bit , 2013/07/22 18:28:29
>> Subversion 1.8.1, -release apr 1.4.8 apr-util 1.5.2 serf 1.3.0 OpenSSL
>> 1.0.1e 11 Feb
>> 2013 zlib 1.2.8
>>
>> Windows 7 Professional SP1, 64 bit
>> Intel HD Graphics 3000 + nVIDIA NVS 4200M
>
> I'm on Win8.1, and I can not reproduce the issue at all. I even installed
> Trillian to see whether I can reproduce it with the chat window there - no
> luck.
>
> Do you have Aero turned off? That might be a clue because that can't be
> turned off anymore in Win8.
>
> I'll commit a small change soon which forces the background of those
> controls to redraw as well, not just the foreground.
> Maybe you can try a nightly build tomorrow (revision > 24943)?
>
> Stefan
>

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3068315

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2013-11-12 13:04:08 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.