[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

SVN hangs sometims on commit dialog

From: Thijs de Ridder <thijs.de.ridder_at_mep-telecom.com>
Date: Thu, 8 Nov 2012 00:50:39 -0800 (PST)

I have a certain working copy where tortoiseSVN hangs sometimes when I try to commit or execute a check for modification (didn't try all svn commands, so other might fail as well). This repository is a little different than the other repositories I'm working with. This repository contains mainly binary fails, varying in size from a couple of KB to a couple of MB.

To reproduce the problem I click right on a certain file in the working copy and click on commit. The commit dialog appears and will not show the file to commit. After a couple of seconds it says "not responding". I had the dialog in this state for more then half an hour, but nothing changes. During this time, the corresponding TortoiseProc.exe takes about 13% of the CPU (on Core i7 860).

I tried to run a clean up on the root of the working copy. This didn't help to solve the problem. After I restarted my computer, I was able to commit a couple of files (3 commits this time, with a different number of files). After those commits, it failed again and the commit dialog hangs.

To see what is the problem, I recorded a successful commit dialog (on a different repository) and the failing commit dialog with DebugView. Attached are both log files.

We had this problem once before. Back then SVN 1.7 was just released. A colleague worked with SVN 1.7 and wasn't able to commit. I was still using SVN version 1.6 at the time and copied his files in my working copy. I was then able to commit them. We didn't investigate the problem any further back then. We do have another repository with mainly binary files. We use that repository far more often then the repository that gives us trouble now. We never encountered problems of this kind in that repository.

Has anybody any idea what can cause this, or how I can further investigate what the problem is?

My system:
Windows 7 professional 64bit (Dutch)
TortoiseSVN 1.7.10, Build 23359 - 64 Bit , 2012/10/08 11:46:26

If any additional information can help, please ask.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3026805

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2012-11-08 09:52:53 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.