[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.7.7 64 bit CLI smart card prompt

From: Joshua Kordani <jkordani_at_intlogsys.com>
Date: Thu, 25 Oct 2012 08:13:46 -0700 (PDT)

Greetings all.

I am trying to use a smart card to authenticate myself to a repository.

I can access many sites properly via a broadcom builtin reader and an omnikey 3021 usb reader. my card is a safenet borderless 400. I am running windows 7 ultimate 64 bit, and have attempted to use tortoisesvn 1.7.10 64bit, collabnet's binary relesae, and the wadisco client as well. With tortoisesvn, I am prompted multiple times to select a client cert (I am prompted with 2, which is correct enough) until eventually failing, instead of being presented with my password prompt. On all of the command line instances, I am presented with a dialog to pass in a client cert file, which I have attempted to do with a der x.509. once doing so, the prompt repeats 3 or 4 times before also failing. I want to get my hands dirty on this, so tell me where to look.

Since the repo is hosted over https I tried browsing to it, and oddly enough I can not browse to it with IE 64bit, but I can browse to it with IE 32 bit. When I use ie, I am only prompted with a gui to pick 1 cert (64bit fails never having asked for my pin), with tortoise svn I am prompted to pick from 2, and then never asks me for my pin and eventually fails.

Thanks

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3023480

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2012-10-25 17:22:57 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.