[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

GSSAPI support in TSVN 1.7?

From: Joseph Giampapa <garof_at_sei.cmu.edu>
Date: Thu, 4 Oct 2012 18:35:56 -0400

Hello,

I am a big fan of TSVN, and would like to upgrade to the 1.7 client for use with my organization's 1.6 servers. Unfortunately, the most recent version of TSVN that I can use is 1.6.16, Build 21511 - 64 Bit, 2011/06/01 19:00:35. The reason is that my organization requires that TSVN use Kerberos to authenticate with its servers, and the latest TSVN 1.7 does not support it.

TSVN 1.7.9, Build 23248 - 64 Bit, 2012/08/30 18:25:37
Error Unable to connect to a repository at URL
Error '<url>'
Error OPTIONS of '<url>': authorization
Error failed: Could not authenticate to server: GSSAPI authentication error:
Error (<url>)

Before sending this message, I did the checklist at http://tortoisesvn.net/reportbug.html:
* Issue not addressed in the Changelog
* I do not load from nightly builds
* There was mention of this in the mailing list archive, but no follow-up.
    http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2934956&orderBy=createDate&orderType=desc
   2012-03-13 Dariush Pietrzark: Is there any chance of GSSAPI/Kerberos authentication working again with newer TortoiseSVNs?
   2012-03-13 Konstantin Kolinko: It is a different question. I'll let somebody else to answer this.

   Nobody did.

* No mention of this in the issue tracker.
* This error does not generate a crash report.

Is there hope, or has GSSAPI/Kerberos not been supported for lack of user community request?

Thank you,
Joseph

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3012942

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2012-10-05 07:12:56 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.