[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Advanced Diff settings can't be Restored to defaults correctly

From: Stain Lessstill <stainlessstill_at_gmail.com>
Date: Tue, 27 Dec 2011 12:14:51 +0400

Restoring to defaults external diff viewer advanced settings leads to
malfunction.
In a nutshell pressing "Restore defaults" in Advanced external Diff viewer
settings restores default extensions without a leading period ('.') that
can be seen thru the registry.

Steps to reproduce:
1. Settings -> External Programs -> Diff Viewer -> Advanced...
2. Remove all entries (extensions and command lines)
3. Press "Restore defaults"
4. Try to diff Microsoft Word file (.doc) from the Log
5. No Word with three-way comparison would be launched - only default Diff
viewer would be launched complaining that it can't diff binary files

Ways to fix it:
1. Press "Edit" for each "default" entry and save it immediately (you see
periods '.' prepended to each extension until you close the settings window)
OR
2. In the registry HKCU\Software\TortoiseSVN\DiffTools prefix periods '.'
to "default" extensions manually.

Is it worth an issue to be fixed?
Thank you.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2902816

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-12-31 03:16:16 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.