[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug: Working copy format error on commit after upgrading to 1.7.2

From: Arjan van Wijk | Tha Narie <thanarie_at_gmail.com>
Date: Tue, 13 Dec 2011 14:32:01 +0100

Hi,

I've checked out an assembla project with svn tortoisesvn 1.7.1, made some
changes, upgraded to 1.7.2, rebooted and tried to commit the changes.

After that I got the following error:
Subversion reported an error:
Working copy
'C:\...path_without_spaces...\' is too old (format 8, created by Subversion
1.4)

There is only 1 .svn folder in the root of the WC.
In there is a 'format' file which contains the number 12, an entires file
which contains the number 12, and a wc.db whichs hows 'SQLite format 3'
when you open it in a text editor.

I've also tried the nightly build, with the same results:
TortoiseSVN 1.7.99, Build 22374 - 64 Bit -dev, 2011/12/12 18:03:54
Subversion 1.7.3, -dev
apr 1.4.5
apr-utils 1.3.12
neon 0.29.6
serf 1.0.0
OpenSSL 1.0.0e 6 Sep 2011
zlib 1.2.5

Installed the old 1.7.1 back, but the WC is still broken.
TortoiseSVN 1.7.1, Build 22161 - 64 Bit , 2011/10/21 22:51:59
Subversion 1.7.1,
apr 1.4.5
apr-utils 1.3.12
neon 0.29.6
OpenSSL 1.0.0e 6 Sep 2011
zlib 1.2.5

I couldn't find any reports like this, could someone verify/fix this, or is
there a workaround so I can commit that WC?
I don't want to use 1.7.2 because I'm afraid my other WC's get broken..

Thanks in advance,
Arjan van Wijk

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2892935

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-12-13 14:33:20 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.