[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

64-bit TortoiseSVN needs to include 64-bit Pageant.

From: Alex Pogrebnyak <alex-pub.tigrissvn_at_reflexion.net>
Date: Thu, 8 Dec 2011 10:08:31 -0800 (PST)

Reproduced on Windows 7, TortoiseSVN 1.7.2

If you install stock Putty ( it's only available as a 32-bit installation from here -> http://www.chiark.greenend.org.uk/~sgtatham/putty/ ), then svn+ssh URLs do not authenticate properly and return very cryptic errors.

If you download and start 64-bit Pageant from here -> https://splunk.net:444/w/PuTTy64bit/files.xml?action=download&file=pageant.exe

then everything works as expected.

I think 64-bit version of TortoiseSVN cannot communicate properly with 32-bit version of Pageant.

Because of this, I think 64-bit TortoiseSVN MUST include 64-bit version of Pageant and documentation MUST stress that 64-bit Pageant must be running, in order to provide passwordless SSH authentication.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2891652

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-12-08 19:10:26 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.