[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Cannot checkout or update on Vista

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 10 Aug 2011 21:18:16 +0200

On 10.08.2011 15:34, Arka Roy wrote:
> (I am sending this again, as I believe I may still have been on
> moderation when I sent it the first time. If it arrives twice I
> apologize in advance, please ignore).
>
> Hi,
>
> I have been using Tortoise SVN on Windows XP (SP 3), without any
> problems. Speed and all other aspects are smooth and fine.
>
> However I recently starting using on a Windows Vista (SP 2) partition on
> the same machine (a 32-bit Dell Latitude E6500). So I am using the same
> machine, in the same office, via the same LAN. The only difference I
> can see is XP versus Vista.
>
> However SVN is very problematic on the Vista partition. I am not able
> to update or checkout that same repository. If I try to update I just
> get the blank update dialog (with an initial message at the top that
> says "Command Update") and a spinning cursor, forever.

I assume the working copy is on a shared (between XP and Vista) partition?
Then you have to manually add your Vista user with full privileges to
the working copy folder.

>
> Checkout actually starts to checkout, creates the local folder, and some
> files do start getting downloaded. However it is very slow. After
> reporting the added files, it doesn't end, but the dialog just remains
> stuck there, with the cursor continuing to spin.
>
> In either case the Cancel button doesn't work. However if I press the
> close box at the top left the dialog closes.
>
> Is anyone aware of issues or factors in Vista that may be difference and
> having an effect?
>
> I have Vista's UAC (User Account Control) setting off.

For your own security, you should turn it on again.

> I also saw a report by someone having the same problem here.
> http://svn.haxx.se/tsvnusers/archive-2007-08/0055.shtml
> The reply, by Stefan Küng, suggested he looks at this Microsoft site
> below. I tried what it said there, ipconfig /flushdns, but to no avail.
> http://support.microsoft.com/kb/939882
>
> I also tried shutting off my antivirus software, this didn't help either.

Maybe this might help:
http://www.tomstricks.com/how-to-fix-slow-file-transfer-problem-in-windows-vista/

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2814085
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-08-10 21:18:45 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.