[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bizarre (but very annoying) problem with TortoiseSVN

From: Robin Guest <robin.guest_at_gmail.com>
Date: Thu, 12 May 2011 14:52:22 +0100

On 12 May 2011 14:43, Andre.Ziegler <MagicAndre1981_at_live.com> wrote:

> this happens because of the UAC. the IE runs in low IL (protected
> mode) and the TSVNCache.exe runs in medium IL so a second instance in
> low IL must be started to show the overlay status for low IL apps. If
> you start an application elevated and call the Open/Save Dialog you
> see a 3rd TSVNCache.exe started. This time with high IL.
>
> Wondering why I've never experienced this - running Win7 64-bit with both
32 and 64 bit versions of TSVN installed, and IE8. UAC is set to second
level (Notify me only when programs try to make changes to my computer (do
not dim my desktop). I have Icon Overlays set to Default, and Show Overlays
and Context Menu Only in Explorer unticked.

When I bring up an open file dialog in IE (such as gmail attach file) I see
the overlays and don't get the OP's security warning.

(I always make a point of developing with UAC turned on even though it's
such a pain, as all the possible UAC-related issues in the code can be
sorted out early on.)

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2735027

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-05-12 15:52:27 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.