[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

tortoiseSVN 1.6.11 (stable) links against neon 0.29.4 resulting in handshake errors

From: Phillip Merensky <mail_at_phillme.de>
Date: Mon, 08 Nov 2010 17:02:14 +0100

Hello guys.
It took me quite a long time to figure out that the ssl handshake
errors I get when I connect to my svn server, relate to the linkage of
TortoiseSVN 1.6.11 against neon 0.29.4. TortoiseSVN 1.6.10 which is
linked against neon 0.29.3 works flawlessly and so does the nightly
build of the 1.6. which also links against neon 0.29.3.
Further details of the issue can be found here
http://bugs.gentoo.org/show_bug.cgi?id=340825.
The neon bug seems to be fixed in neon 0.29.5
(http://www.webdav.org/neon/ "Fix GnuTLS handshakes failures with 'TLS
warning alert' (Bryan Cain)").

I think that issues like
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2670355 could be solved like this,
too.

Would it be possible to release a quick fix tortoiseSVN version for
this issue (link against neon 0.29.3 or 0.29.5) so that the current
stable version of Tortoisesvn is not longer leading to this bug?

This would be very nice.
Thank you in advance

Phillip Merensky

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2679979

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-11-08 17:05:09 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.