[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Kerberos + GSSAPI support in Tortoise SVN

From: Jean-Yves Avenard <jyavenard_at_gmail.com>
Date: Wed, 29 Sep 2010 12:18:11 +1000

On 29 September 2010 11:47, Jean-Yves Avenard <jyavenard_at_gmail.com> wrote:
> My understanding is that the MIT Kerberos gssapi is linked statically
> to saslGSSAPI.dll ; and as such as no dependency on any other libs..
>

Ok..

My mistake.

I have uninstalled MIT Kerberos for Windows (official distribution),
and indeed, SVN update on a SVN repository requiring kerberos
authentication will fail silently. No windows show up with any errors
whatsoever.

Adding the DLL:
comerrX.dll
gssapiX.dll
kr5sprtX.dll
krb5_X.dll
krb5_X.dll
(where X is either 32 or 64 bits) does make TSVN show a window, and it
automatically revert to basic authentication

It does add over 1MB to the package :(

I'm going to send you another update, this time the gssapi.build will
copy the dll in the proper location so the installer as you made it
will work.

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2665918

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-09-29 04:18:25 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.