[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Overlay icons (Shell) sometimes don't refresh

From: Bob Archer <Bob.Archer_at_amsi.com>
Date: Fri, 17 Sep 2010 13:57:07 -0400

> I have TortoiseSVN 1.6.10, Build 19898 - 32 Bit , 2010/07/16
> 15:46:08
> on Windows XP Pro SP3.
>
> I have a WC from a local repo (file:///F:/something/foo/...).
>
> I have set Icon Overlays Status cache to "Shell".
>
> In the WC I created a new folder and two text files in it.
> Then I added the folder (and content) to SVN, but the icons were
> not showing the
> new status.
> I also commited them but the icons are still as for normal files
> (non-SVN).
>
> I tried F5 several times, also closing all Explorer windows.
>
> Other folder in the same parent folder have the correct SVN
> overlays.
> They are not in exclude path. (actually all my drives are in
> exclude
> and the WC parent folder is in include path).
>
> Any idea why it is not working?
>
> If I change an older text file in same WC, it's icon changes even
> without F5.
>

What folder view are you looking at. If it is in the treeview of XP's explorer... those are pretty much never right. They only update when you close any containing folders, F5 then re-open them. Folders in the list view of the XP explorer should always update when you press F5 when using "shell" overlay mode.

http://tortoisesvn.net/node/146

BOb

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2661367

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-09-17 19:57:21 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.