[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Problem when creating patch at the installed Japanese Language Pack.

From: NM <matsuda_at_hitachi-mc.co.jp>
Date: Fri, 25 Sep 2009 21:53:25 +0900

Hello,

The "REVISION" string is written into patch file created by [Create patch].
In environment where Japanese Language Pack is installed, "REVISION" is
written in Japanese.

Character code of the "REVISION" string is Shift_JIS absolutely.
Unfortunately, Various character codes exist in Japanese.

Patch file created from the file written by Shift_JIS is completely
satisfactory.
However, Patch file created from the file written by utf-8 cannot be used.

"REVISION" by Shift_JIS and source-code by utf-8 are mixed inside of
created patch file.
This patch file does not become useful.

I think, "REVISION" string in patch file should be written not in
Japanese (multi-byte) but in English (single-byte).

Additionally, This problem is not solved, even if it sets language as
English or uninstalls a Japanese language pack.
Seemingly, it will solve, if a [C:\Program
Files\TortoiseSVN\Languages\ja] folder is deleted.

Thanks,

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2400217

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-09-25 17:05:10 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.