[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Strange new problem with tree conflicts

From: Jeffrey Simon <jas_at_rephunter.net>
Date: Tue, 8 Sep 2009 11:57:14 -0500

For no apparent reason, I have tree conflicts in my project. I am
thinking this might be a bug in TSVN for the following reasons:

1. There is no reason that such a conflict should be reported.

2. All of the files in my working copy in all three branches and in
the repo are respectively identical on a per file basis.

3. My repo structure has three branches within it as follows
        - dev
                - current
                - stable
                - production

The tree conflict shows up for a couple of dozen file when I do a
commit on dev. However, when I do a commit on each of the three
branches separately, no tree conflict is shown.

4. When this first happened a week or so ago, I checked out a whole
new copy of dev. After than, no tree conflict was reported for a few
days. Then suddenly, it showed up again. Nearly all the the files with
the reported tree conflict have been changed any time recently.

5. I have also tried cleanup on TVSN 1.6.3, just to see if it helped,
but it does not. So then I updated to 1.6.4.16974 and ran cleanup
again. This time, after cleanup, the bang icon on the folder went
away. But trying the commit on that folder still has the tree confilct
on the same set up files.

Accordingly I believe this reported tree conflict to not be a real
problem, but some artifact or bug.

Any one see this?

If it is not a bug in TSVN, then how do you fix it?

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2392569

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-09-08 19:03:50 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.