[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Repository browser displays an error after upgrading the SVN server to 1.6.2

From: Kurt Pruenner <leak_at_gmx.at>
Date: Tue, 26 May 2009 14:11:59 +0200

Martin Bischoff wrote:
> If I invoke the repository browser on any existing working copy, I get
> the following error message (in the right pane of the repository
> browser):
>
> 'svn://SERVER/repository/trunk/xyz' isn't in the same repository as
> 'svn://server/repository'
>
> There seems to be a problem with upper-/lowercasing of the server name.
> All other operations (update/commit) seem to work without problems.
>
> What is the reason for the problem and how to proceed to solve it?

Well, the servername in the URL ought to be case-insensitive, but I
guess SVN doesn't currently handle it that way.

Anyway, doing a "TortoiseSVN > Relocate" on the working copy to the URL
with the lowercase server name should fix things in that case.

-- 
Kurt Bernhard Pruenner --- Haendelstrasse 17 --- 4020 Linz --- Austria
.......It might be written "Mindfuck", but it's spelt "L-A-I-N".......
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2353773
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-05-26 14:29:27 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.