[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: TSVN problem with shared folders & local repositories

From: David Balažic <david.balazic_at_hermes-softlab.com>
Date: Wed, 20 May 2009 09:41:28 +0200

Simon Large:

> 2009/5/19 Stefan Küng <tortoisesvn_at_gmail.com>:
> > Jeremiah J. Blanchard wrote:
> >> Hello there,
> >>
> >> I've been using TortoiseSVN for several years now. I
> recently upgraded
> >> to the latest TSVN from 1.4.8 and ran into some problems.
> >>
> >> Here's the repository setup:
> >> Shared folder on another computer in the LAN; ie,
> >> file:///\SomeHostName/Folder/SVN.
> >
> > For UNC paths, the correct url is
> > file://somehostname/Folder/SVN
> >
> > at least with clients >= 1.5.x
>
> Oops, you're right.
>
> file:///c:/folder/svn [ Windows local drive ]
>
> file://hostname/folder/svn [ localhost or UNC path ]
>
> file:///folder/svn [ Works for local folders on *nix but
> not Windows ]

Because Windows has no root directory or a "folder" named root entry.
file:///C:/foo/bar does not work on *nix either.
Any URL "pointing" to a file that does not exist will "not work".

Regards,
David

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2326422

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-05-20 09:41:29 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.