[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Svn not able to open file due to wrong syntax.

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Mon, 27 Apr 2009 15:30:05 +0200

Lübbe Onken wrote:
> webpost_at_tigris.org wrote:
>> Hi,
>> I am running 1.6.1 on XP that is running in vmware fusion (vmware on mac).
>>
>> I have a shared FAT32 partition which i then use as DATA drive between XP and mac OS X. This is where my svn folders are located and everything has worked fine for a long time untill recently.
>
> *SHARED* FAT32 partition...
>
> Is it possible that you are accessing your working copies with different
> svn clients? Like tortoisesvn 1.6.x on XP and subclipse (older) on the mac?
>
> If one client updates, it also silently updates the working copy to the
> latest format which prevents older clients from accessing them.

And you get the same corruption as if you're using a working copy on Win
and Linux (or Win and cygwin, or Win and Mac, or ...).

My best guess: your working copy is hosed. Do a fresh checkout and let
this be a lesson to never do this again.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=1946010
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2009-04-27 15:30:19 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.