[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Show log in 1.6 very slow compared to 1.5

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Sat, 18 Apr 2009 13:44:31 +0200

On Sat, Apr 18, 2009 at 12:49, Stefan Fuhrmann
<stefanfuhrmann_at_alice-dsl.de> wrote:
> Heiko Tappe wrote:
>> Every time I want to see a log (large! - like on "root of trunk") for
>> the first time (e.g. after reboot) I have to wait for more than 1
>> minute. The same with 1.5: maybe 1 or 2 seconds.
>> The second attempt is much faster but still needs 3 or 4 seconds.
>>
>> "Wrong" settings?
>
> Not your fault. It is because TSVN scans the whole WC for
> the last committed version and will then highlight it. The
> problem here is that it won't show any data until the scan
> is done (just press cancel and you will see the log w/o highlight).
> I plan to fix that in 1.7 by scanning the WC asynchronously.

Good idea!
Done in r16201.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=1788233
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-04-18 13:44:59 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.