[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TSVNChace in endless loop on network file system: 1.5.6, Build 14908

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Fri, 16 Jan 2009 16:33:13 +0100

postmaster_at_tigris.org wrote:
> I wanted to test the hypothesis of wheather this was the network
> driver or some corrupted file in the work area.
>
> I zip'ed up the full work area on my system drive and un-zipped it to
> my C-drive.
>
> TSVN seems to be pretty happy with all the data in my C-drive. It is
> spending alot of time crawling files but it just keep crawling, never
> hangs. While crawling the cpu stays pretty low, 1-10%. The explorer
> window never behaves strangly.
>
> So it really appears it is un-happy with the network drive.
>
> Any other thoughts to try?

So:
cache on network drive: doesn't work
cache on local drive: works

but: would it work if the wc is copied to another location on the
network drive?

If it works if you create another copy of your wc on the network drive,
then you have to expect the worst (e.g., bad harddrive sector).
If it doesn't work there either, then your network share protocol is to
blame (that's why we have repeatedly advised against keeping a wc or
repository on a network share).

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=1028936
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

Received on 2009-01-16 16:33:40 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.