[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem with Icon overlays

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 15 Oct 2008 21:00:51 +0200

Carrow, Amanda R wrote:
> Once I did the upgrade to the most recent version of Tortoise, the Icon
> Overlays did not work properly.
>
> For example, I added a new folder to the project. The folder had no
> overlay to show it had been added. When I committed the change, the
> folder still had no overlay on it.
>
> When I tried deleting folders the overlay didn’t show that they had been
> deleted from the working copy.
>
> And none of the parent folders show when a change is made inside. They
> still have the green check mark on the icon, even when the content has
> been changed.
>
> The only time that the overlays look the way they should is right after
> log into my computer.

* did you reboot after upgrading?
* is your working copy on a network share? If yes, the overlays won't
update properly for some shares - only default windows shares seem to work
* check the registry entries under
HKLM\Software\Microsoft\Windows\CurrentVersion\explorer\ShellIconOverlayIdentifiers
  only 9 entries from TortoiseSVN should be listed there
(xTortoise<Status>) - if you have more entries from TSVN, delete them
and do a fresh install
* You might have to hit F5 in explorer to refresh the overlays

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net

Received on 2008-10-15 21:01:08 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.