[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Overlay icons not displaying in some apps in Vista

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Tue, 14 Oct 2008 19:17:58 +0200

Jeff Alperin wrote:
> I'm using Vista SP1. I have Tortoise SVN properly installed and
> configured, and the overlay icons always display properly in Windows
> Explorer. However, they do NOT display in Total Commander or when
> viewed through the Open File dialog in NotePad, Paint, UltraEdit and
> probably many other programs when the program is run with elevated
> privileges (selecting the "Run as administrator" option). That's right;
> the problem occurs when the "viewing" application has MORE privileges.
>
> Tortoise CVS does not have this issue; I can see the overlay icons for
> it regardless of whether the "viewing" application is run with elevated
> privileges.
>
> Is this a bug? Is there a workaround (other than running with
> non-elevated privileges)? Thanks.

You can change the overlays settings from "default" to "shell".
The overlay cache is only started once per session - if you use "runas",
the processes can't access the already running cache because it runs
with other privileges.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net

Received on 2008-10-14 19:18:21 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.