[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Re: Tortoise Crashing when proxy not configured properly - not able to change it either

From: Chadwick, Steve <steve.chadwick_at_intel.com>
Date: Sun, 12 Oct 2008 07:37:40 -0700

I have been deleting both sets of registry keys - I figured that they were copies, etc. However, this isn't it - - I still crash :-(

Also, when it crashes, it is a hard crash - no option to create a dump file - at least no dialog appears.

I have attached a screen capture of the registry. The password is a combination of special characters, numbers and letters, but obviously omitted.

Thanks!

Steve Chadwick

-----Original Message-----
From: Stefan Küng [mailto:tortoisesvn_at_gmail.com]
Sent: Sunday, October 12, 2008 8:16 AM
To: users_at_tortoisesvn.tigris.org
Subject: Re: Tortoise Crashing when proxy not configured properly - not able to change it either

Chadwick, Steve wrote:
> Stefan,
>
> I deleted the keys and then waited. They did not reappear. I deleted
> from two places. I found them in
> hkcu\software\tigris.org\subversion\servers\global and then in
> TortoiseSVN\Servers\global.
>
> I also checked the %appdata% and those files had all #'s in there - so
> nothing should be executing in those files.
>
> I then checked the registry again - nothing created (waited about 5
> minutes). I don't believe I have any other clients on the machine
> either - but one never knows I guess...
>
> I then opened up the network and ever so briefly the old information I
> had in there flashed on the screen right before it crashed. I then
> checked the registry - the values were back again.
>
> Also, and I think that this might be a clue... The values only appear
> when I click on the network tab. If I start up the Tortoise and do
> some other stuff in there - no issues. The keys are only created in
> the registry when the network tab is hit. So I think that I can say
> with some confidence those two are related.
>
> I have also tried clearing the keys from the registry and then tried
> rebooting. My thought is that maybe the form is holding those keys
> somewhere in memory. However, when I logged back in and tried again,
> the keys were again written to the registry. I have tried searching
> the registry for my entered password, it didn't show up... I also
> tried the HD - it wasn't there either - not in plain text anyways.

Completely forgot about that: there are copies of those settings also stored in the registry under HKCU\Software\TortoiseSVN\Servers\global

Try deleting those too (also delete the other ones).

But again: before you delete those keys, please write the values down and send them to me (if your password is in there too, just replace it with XXX or something like that - I only need the raw data which makes it crash).

> Does any of this help? Is there a way to generate and send you a dump
> file that maybe has some clues?

When an application crashes, a dialog pops up from where you can get the crash dump file.

Stefan

--
       ___
  oo // \\ "De Chelonian Mobile"
 (_,\/ \_/ \ TortoiseSVN
   \ \_/_\_/> The coolest Interface to (Sub)Version Control
   /_/ \_\ http://tortoisesvn.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org

10-11-2008 5-38-31 PM.png
Received on 2008-10-12 16:40:53 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.