[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: permissions problem with working copy on network drive

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 01 Oct 2008 18:37:14 +0200

Aaron Solochek wrote:
> I am using TortoiseSVN 1.5.3, Build 13783 - 32 Bit on windows XP pro, and my
> working copy is on a network drive. This setup is necessary for reasons I've
> detailed in previous posts on this list.
>
> Since updating to the 1.5.X versions, I've been experiencing problems with
> committing. Commits always fail:
>
>> Command Commit
>> Adding H:\foo\bar
>> Sending content H:\foo\bar
>> Error Commit succeeded, but other errors follow:
>> Error Error bumping revisions post-commit (details follow):
>> Error In directory 'H:\foo'
>> Error Error processing command 'committed' in 'H:\foo'
>> Error Can't move 'H:\foo\.svn\props\bar.svn-work' to
>> Error 'H:\foo\.svn\prop-base\Makefile.svn-base': Access is denied.
>> Finished!
>
> Like I said, I never had this problem before 1.5. I have removed and re-checked
> out the code in case it was due to some problem in the 1.4->1.5 conversion, but
> that made no difference.
>
> Looking at the file on the machine running the samba server, its mode is 544,
> and via cygwin on the machine with the network share, it is 444. Windows just
> shows that the file is read-only and an archive.
>
> Did tortoise 1.5 change the permissions that it creates the .svn-work files
> with? Is there a fix for this?

http://tortoisesvn.tigris.org/faq.html#samba

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net

Received on 2008-10-01 18:37:41 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.