[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn+ssh oddness

From: Sam Barnett-Cormack <s.barnett-cormack_at_lancaster.ac.uk>
Date: Wed, 01 Oct 2008 12:45:00 +0100

Sam Barnett-Cormack wrote:
> So, I've got an odd situation, and I was wondering if anyone here had
> any idea what it means.
>
> I've been using a linux-based repo via file:/// urls. I am trying to
> access the same repo over the network using svn+ssh. I use the url
> svn+ssh://name@host.name/path/to/repos/path/in/repos/. I get a password
> prompt (pubkeys are not usable on this server, I have no idea why) and
> enter the password. I get another prompt. I get 7 in total, and they all
> disappear without an error, until the last and I get the error
> "connection closed unexpectedly" (or words to that effect).
>
> Trying to diagnose the issue, netstat tells me that all seven create
> connections, and they all hang around for a while in state TIME_WAIT.

Trying the same thing with a command line client, I get an error
specifying that svnserve couldn't be found, so it's a whole different
situation and not tortoise's fault... my svnserve isn't on the default
PATH, it's in my home directory on the server, and I don't have root...

Sam

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-10-01 14:57:43 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.