[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Plink window showing after upgrade to 1.5.3.13783

From: pbj <v7jn2sgtio001_at_sneakemail.com>
Date: Wed, 3 Sep 2008 08:33:54 -0700 (PDT)

Problem resolved -- it looks like during the upgrade, TSVN lost track
of TortoisePlink. Maybe I had previously set the external SSH client
to TortoisePlink.exe (I just don't remember) -- if so, the upgrade
seems to have resulted in that setting getting lost. Apparently TSVN
is smart enough to find Plink.exe in my system folder and run that
instead (with the accompanying annoying window!). If I hadn't had
Plink.exe on my system, the connection would have failed out-right.

When I set the external SSH client (in Settings|Network) to
TortoisePlink.exe (in C:\Program Files\TortoiseSVN\bin) I have
returned to previous behavior (connection succeeds with no annoying
windows).

Maybe this will help someone else who experiences the same issue.

Paul

On Sep 3, 11:12 am, pbj <v7jn2sgtio..._at_sneakemail.com> wrote:
> First of all, I'm a long-time daily user of TortoiseSVN -- I love it!
> Thanks for all the good work.
>
> After updating to 1.5.3.13783 (on Windows XP SP3), every svn (svn+ssh)
> operation results in a Windows command-line window opening with
> "Plink" in the title bar.  Some operations (eg. "Show log") can cause
> multiple such windows.  It seems that the manner in which TSVN is
> invoking Plink has changed in some way.  This is happening on multiple
> machines and when talking to multiple different servers.
>
> It would not be *that* big of a deal except that each of these windows
> force themselves to the foreground thus making the machine very
> difficult to work with while the operation is in progress.  Thus, I am
> assuming that this change of behavior was inadvertant.
>
> Note that the connection succeeds and svn operations are successful,
> it is just the new, annoying, visibility of this blank command-line
> window that is different.  Am I the only one with this problem?
>
> Thanks,
> Paul
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscr..._at_tortoisesvn.tigris.org
> For additional commands, e-mail: users-h..._at_tortoisesvn.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-09-03 17:37:26 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.