[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "The Patch Seems Outdated! The File Line...And The Pathcline Do Not Match" - But they do!

From: BenTaylor <ben.taylor.uk_at_gmail.com>
Date: Mon, 1 Sep 2008 02:43:07 -0700 (PDT)

Hi Stefan,

I was not on the latest version <sound of wrist slapping>, but I have
just upgraded and re-created the patch. Unfortunately, I still get
exactly the same problem when I try and apply the patch.

When I posted this I was using 1.5.2, Build 13595 - 64 Bit, 2008/07/31
17:04:57. I have now upgraded to 1.5.3, Build 13783 - 64 Bit.
However, the problem is still the same (I did reboot and confirm that
TortoiseSVN had changed version number).

Is the bug in anyway related to checkout, or is isolated to the patch
functionality? I ask, because I have not tried checking out a fresh
source tree, re-doing the work, and THEN re-creating the patch.

Thank you for responding so quickly. It is much appreciated (I am off
to your donation page right now!).

Ben

On Aug 31, 4:02 pm, Stefan Küng <tortoise..._at_gmail.com> wrote:
> BenTaylor wrote:
> > Hi All,
>
> > I have looked in the archives but have not been able to find an answer
> > to my issue.  I have created several patches for an open source
> > project called dasblog.  However, when I try to test apply the patches
> > on a clean source tree I get the error message:
>
> > "The patch seems outdated!  The file line <snipped> and the patchline
> > <snipped> do not match!"
>
> > In reality the two <snipped> tags contain the contents of the line,
> > but both are exactly the same, and appear exactly the same when I view
> > them both in Notepad2 (with CR LF and whitespace showing).
>
> > Can anyone tell me how to solve this issue?  Am I doing something
> > wrong?
>
> > If it helps, I have written the issue in full with screenshots on my
> > blog here:
>
> >http://bentaylor.org/The-Patch-Seems-Outdated-The-File-LineAnd-The-Pa...
>
> Which version of TSVN/TortoiseMerge are you using? This should have been
> fixed a long time ago: the reason the patch doesn't work is because of
> the unicode markers at the beginning of the file.
>
> Stefan
>
> --
>        ___
>   oo  // \\      "De Chelonian Mobile"
>  (_,\/ \_/ \     TortoiseSVN
>    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
>    /_/   \_\    http://tortoisesvn.net
>
>  signature.asc
> < 1KViewDownload

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-09-01 11:43:39 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.