[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: [SPAM] Re: TSVNCache.exe bug

From: Pj <pj_at_netfire.com.au>
Date: Thu, 14 Aug 2008 09:57:58 +0800

:) Yes this was giving me hell, resulting in a 2-5 minute wait EVERY time I
accessed an explorer window or variant. (Boss: "Pj! Why isn't that release
ready?" Pj: "Because my ***** computer isn't responding!" Can you imagine
the anguish? You have all been there right?

The short term work around until they fix this, You can turn off
TSVNCache.exe
Set Status Cache = none in Icon Overlays in the settings panel.

Please Tortoise guys, can you launch this process with a lower priority and
or add a tuning algorithm so it only consumes a small amount of cpu?
Sleeping a tunable Z milliseconds every N times through your IO loops might
be a simplistic workable approach.

Regards
Pj.

-----Original Message-----
From: Keith [mailto:keithhoffman22_at_gmail.com]
Sent: Thursday, 14 August 2008 12:26 AM
To: users_at_tortoisesvn.tigris.org
Subject: [SPAM] Re: TSVNCache.exe bug

I'm observing this issue with 1.5.2.

After running an update, which sometimes runs very slowly,
TSVNCache.exe will continue to use 50% cpu (1 core) for a few minutes
after the update has completed. It will then drop to 4-8% CPU but its
memory usage will continue to grow. In this specific instance of this
behavior, it grew from around 24MB at the time of completion of the
update to 106MB. When the memory usage stops growing, cpu usage drops
to 0%.

I'd say there are two problems:
1. Why is TSVNCache using 100% of a cpu core?
2. Why is it using 100MB?

Cheers,

Keith

On Jul 26, 8:52†am, Stefan KŁng <tortoise..._at_gmail.com> wrote:
> ThomasD wrote:
> > Hi,
>
> > I have TSVNCache.exe always using 100% CPU. On a quad core PC, it hogs
> > a full core.
>
> > I have run it with filemon and found it checks all the files in a
> > loop, constantly, with no pause.
>
> > I have the latest version and it's running on Windows Vista 32 bits.
> > The files are on a local drive and I have also tried to shut down
> > everything to see if there are any interactions... with no luck.
>
> > I can see a few people have the same issue, but I have not seen a
> > solution yet :(
>
> Please try version 1.5.1
>
> Stefan
>
> --
> † † † † ___
> † †oo †// \\ † † †"De Chelonian Mobile"
> † (_,\/ \_/ \ † † TortoiseSVN
> † † \ \_/_\_/> † †The coolest Interface to (Sub)Version Control
> † † /_/ † \_\ † †http://tortoisesvn.net
>
> †signature.asc
> < 1KViewDownload

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org

No virus found in this incoming message.
Checked by AVG - http://www.avg.com
Version: 8.0.138 / Virus Database: 270.6.1/1608 - Release Date: 8/12/2008
4:59 PM

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-08-14 03:59:36 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.