[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SASL Encrpytion Not Working

From: Sparrow Hawk <sprhawk_at_gmail.com>
Date: Wed, 6 Aug 2008 18:02:50 -0700 (PDT)

Thank you !

On Aug 5, 11:45 pm, TomDeWord <collabnet..._at_vixx.co.uk> wrote:
> Please see above; Stefan produced a release candidate build of 1.5.2 -
> Build 13608 (available from the nightly builds) which includes support
> for RC4 encryption - you've installed build 13595 which doesn't have
> the fix (maybe it will officially arrive in 1.5.3).
>
> Regards
>
> Tom
>
> On Aug 4, 11:39 am, Sparrow Hawk <sprh..._at_gmail.com> wrote:
>
>
>
> > I still have problem on SALS.
> > I compiled the tarball of the svn-1.5.1 r32289 under slackware 12
>
> > I downloaded the latest :
> > TortoiseSVN 1.5.2, Build 13595 - 32 Bit , 2008/07/31 17:04:57
>
> > I set up the svnserve.conf like:
> > use-sasl = true
> > min-encryption = 128
> > max-encryption = 256
>
> > /usr/lib/sasl2/subversion.conf:
> > pwcheck_method: auxprop
> > auxprop_plugin: sasldb
> > mech_list: CRAM-MD5 #DIGEST_MD5 is the same
>
> > the CollabNet's svn command-line client (svn.exe) could work with this
> > configuration,
>
> > but the TortoiseSVN could not.
>
> > I can't figure out the problem.
>
> > On 82, 3ʱ43, Stefan Kng <tortoise..._at_gmail.com> wrote:
>
> > > TomDeWord wrote:
> > > > Excellent detective work Stefan, I've downloaded and tried the
> > > > currently nightly build (TortoiseSVN 1.5.2, Build 13608 - 32 Bit -dev,
> > > > 2008/08/01 18:41:21) and all seems to be working well with min/max-
> > > > encryption set to 128/256 (although I've not snooped the svn traffic
> > > > to confirm that it's actually encrypted!); did a simple commit &
> > > > compare with no corruption.
>
> > > > Is there a way to change the server to use DES over RC4 or does this
> > > > require a rebuild of the core SVN distro?
>
> > > I don't know if you can configure the official svn build to use DES. I
> > > thought that it would use DES by default, but apparently DES only worked
> > > with TSVN when I used the svnserve I built myself (which had RC4 not
> > > built in).
> > > Since TSVN does not work with the collab.net build, I have to assume
> > > that they didn't build DES support into their binaries. If they had, I
> > > would assume that server and client would negotiate about what
> > > encryption type to use.
>
> > > Stefan
>
> > > --
> > > ___
> > > oo // \\ "De Chelonian Mobile"
> > > (_,\/ \_/ \ TortoiseSVN
> > > \ \_/_\_/> The coolest Interface to (Sub)Version Control
> > > /_/ \_\ http://tortoisesvn.net
>
> > > signature.asc
> > > 1K
>
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscr..._at_tortoisesvn.tigris.org
> > For additional commands, e-mail: users-h..._at_tortoisesvn.tigris.org- Hide quoted text -
>
> > - Show quoted text -
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscr..._at_tortoisesvn.tigris.org
> For additional commands, e-mail: users-h..._at_tortoisesvn.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-08-07 07:01:50 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.