[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Re: Re: Disable tortoiseSVN from Automatic upgrading to 1.5 client

From: Andy Levy <andy.levy_at_gmail.com>
Date: Mon, 7 Jul 2008 21:22:35 -0400

On Mon, Jul 7, 2008 at 19:43, Todd Carmichael <toddc_at_concur.com> wrote:
> Ok. Can the SVN libraries be configured to create 1.4.x working copies? If
> so, a tortoise UI on that configuration would be quite useful.

No, they cannot. Otherwise you would have thousands of people confused
as to why their 1.5 clients don't work properly with 1.5 features
because their WC hasn't been upgraded to support those features.

> ________________________________
> From: Larry Shatzer, Jr. [mailto:larrys_at_gmail.com]
> Sent: Monday, July 07, 2008 3:16 PM
> To: users_at_tortoisesvn.tigris.org
> Subject: Re: Re: Disable tortoiseSVN from Automatic upgrading to 1.5 client
>
> On Mon, Jul 7, 2008 at 4:10 PM, Todd Carmichael <toddc_at_concur.com> wrote:
>>
>> Thanks for your response. I have reverted to tortoise 1.4.8 which can
>> be found here:
>> http://sourceforge.net/project/showfiles.php?group_id=138498&package_id=
>> 151948
>>
>> There should be an option within Tortoise to write pre-1.5 working copy
>> files. Otherwise, Tortoise 1.5 will have limited adoption.
>>
>
> It is not TortoiseSVN that does the conversion, it is the Subversion
> libraries that TortoiseSVN links to. So it would be impossible for
> TortoiseSVN 1.5 to write 1.4.x working copies, since TortoiseSVN 1.5 is
> linked to 1.5 Subversion libraries.
>
> -- Larry
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-07-08 03:23:10 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.