[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug Windows SubMenu problem 1.4.8 & 1.5-RC3

From: Stefan Kng <tortoisesvn_at_gmail.com>
Date: Mon, 16 Jun 2008 21:33:46 +0200

Hanspeter Widmer wrote:
>
>
> Hello
>
>
>
> I just have a problem on specific folder where the submenu (folder right
> click) shows
>
>
>
> - using V1.4.8 a garbage (empty menu list)
>
> - using 1.5 RC3 shows the menu entries with any icons and NO
> actions are done on each menu (just do nothing happends)
>
>
>
>
>
> On this folder there are about 180 entries (29 subfolders and rest
> files). I just moved away some files to an other folder and surprise
>
> The context menu was OK. Conclusion it happens file count dependent!

I assume your working copy is on a network share, or your harddrive is
slow. The reason the menu is empty is that the explorer has a timeout
for menus (to prevent faulty extensions from blocking it). The TSVN
context menu has to fetch the status of the selected item. If you have a
very big folder and a slow harddrive, then you'll hit that timeout.

there's nothing we can do to prevent that (apart from not fetching the
status).

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net

Received on 2008-06-16 21:34:56 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.