[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Update: RE TSVN bug

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Fri, 06 Jun 2008 18:16:19 +0200

Simon Berry wrote:

> I previously reported that the TSVNCache.exe hanging issue seemed to be
> fixed in version 1.5 ( I am using 1.5.0 build 12608).
>
> However today I noticed that TSVNCache suddenly started using > 50% CPU
> load (see attached cpu.jpg)
>
> Looking at the task in more detail, the 'I/O reads' and 'I/O writes' are
> pretty constant, but the 'I/O Other' is shooting through the roof -
> going up by approx 1000 per second and the 'I/O Other Bytes' is
> incrementing by approx 25K per second.
>
> I have also attached a cut down dump from process monitor which shows
> that TSVNCache is cycling through the same 5 or 6 files/locations every
> 100ms - almost as if it is stuck.
>
> I hope this helps to track down the problem...

* can you reproduce the problem if you kill the process and have it
start again?
* is your R:\ drive a network drive? A SUBSTed one?
* what's the status of the files and folders directly under R:\?
   (use the Check-for-modifications dialog, show all columns)

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net

Received on 2008-06-06 18:16:32 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.