[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug Report

From: Twilight Princess <sirina.tarika_at_gmail.com>
Date: Thu, 1 May 2008 17:51:04 +0200

Description: TortoiseSVN does not play nice with soft links (aka
symbolic links).
Full explanation: If the log viewer is launched inside a source
directory accessed via a symbolic link, it will fail. In latest
stable, the program will display an error it cannot find
"source_directory\..\.svn" (parent directory of source directory). In
latest trunk, an error will display, but it's empty.
How to reproduce: On my system, I have the source stored in C:\Ascent
Source. I also have a symbolic link at D:\Stuff\Wow\Ascent Source to
C:\Ascent Source.
I navigate to my symbolic link to the source directory, right-click ->
TortoiseSVN -> Show log.
When doing this from C:\Ascent Source, everything works fine.
But when trying to do so from D:\Stuff\Wow\Ascent Source, it fails.

I'm not sure if it's actually related to a link or whatever, but I
know that it happens everytime I try.
Using Windows XP Professional, SP2 (NTFS drives, of course).

Please reply directly instead of the mailing list.
Good luck with your software. I wish you the best.

If there is anything missing in the bug report, feel free to bug me.

-- 
The scythe of darkness cuts down everything in its path. Left standing
are only those worthy of being saved from the darkness. But who shall
wield this scythe? No one knows and today there is no answer. Tomorrow
has the answer and yesterday there existed no answer. The scythe will
choose for itself and the chosen shall be revealed in due time to its
reawakening. Beware.
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-05-01 17:51:35 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.