[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Expected format '3' of repository; found format '5'

From: Milen A. Radev <milen_at_radev.net>
Date: Sat, 1 Mar 2008 05:02:35 +0200

On 01/03/2008, Curunir Wolf <harryholt_at_gmail.com> wrote:
> I can't believe nobody else is having this problem, but I can't seem
> to find a solution. I'm running Tortoise SVN version 1.4.8, build
> 12137 on Windows XP. My repository is on a Gentoo Linux box, running
> version 1.4.6 (r28521) of subversion.
>
> I created a new repository, and tried to import a new set of files
> into it, but I get this error:
>
> Error Expected format '3' of repository; found format '5'
>
> Sure enough, the "format" file in the repository subdirectory is, in
> fact "5".
>
> How do I fix this? The only option in 'svnadmin create' is --pre-1.4-
> compatible, which seems wrong because I've been running 1.4 forever.
>
> Any help?

Most probably you've created the repository with version 1.4.x and now
you're trying to use it (import files etc) with version 1.3.x (more
info hre - http://svn.collab.net/repos/svn/trunk/notes/repos_upgrade_HOWTO).

-- 
Milen A. Radev
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-03-01 04:02:48 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.