[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: something wrong with commit -- I don't want to screw this up

From: Kevin Hennessy <perk_at_theabsurd.org>
Date: Mon, 04 Feb 2008 00:08:40 -0800

Hi,

I am not doing a nightly build

>> The state of the working copy is that most folders are up to date
>> (green check), but some have only add icons on them. When I do a
>> commit to put these folders in the repo, I get an error saying "File
>> alread exists". I don't think the contents of these directories are
>> in the repo because by size the repo is a few gigs smaller than I
>> would expect.
>>
>> Something clearly went wrong so that the states of the repo and
>> working copy are not in sync. Any ideas on what went wrong or how to
>> correct this?
>
> Maybe some post-commit hook script failed?
> Run update on your working copy, then try committing again.

OK, I tried this and it failed. Now things look bad...

When I update, I get,

"Error: Failed to add directory 'C:\perk\research\polaritons': object of
the same name already exists"

and when I commit I get

"Error: File already exists: filesystem '/svn/perk/db', transaction
'9-1', path '/research/papers/jvst03' "

What's worrying me is that all of the directories within research/ now
do not have any TSVN icons. What does that mean? Is something really
wrong with the repo?

Man, when something goes wrong, why does it have to be on "research"
instead of "stupid_stuff", "misc", or "porn" -- all those worked fine. :)

thanks a lot guys,

perk

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: users-help_at_tortoisesvn.tigris.org
Received on 2008-02-04 09:08:58 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.