[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TortoiseSVN hoses subeclipse

From: Nicolai Scheer <scope_at_planetavent.de>
Date: 2006-11-09 18:49:52 CET

Hi!

eclipse@purpleblade.net wrote:
[...]
> At any rate now when I use subclipse it tells me that my SVN client is
> out of date and
> that I need to get a later one.

Have a look at http://tortoisesvn.tigris.org/tsvn_1.4_releasenotes.html
Subversion 1.4 uses a new format for the working copies.
Your TSVN did the update automatically when you first touched your
working copy.
So the "old-version" client, subclipse in this case, is not able to
access it anymore.

> Apparently TortoiseSVN overwrote some library that subclipse was using.
> Why I can not
> have two separate or different version of SVN on my machine is puzzeling.
> I would like to get subclipse going again under eclipse. Any ideas
> would be super
> appreciated.

TSVN did not overwrite any libraries. Things will be well if you just
update subclipse. To do so, you have to use the 1.1.x branch of subclipse.
Just start eclipse, goto "Help"->"Software Updates"->"find and install".
Then "Search for new features...", and add the following update site:

name: subclipse
url: http://subclipse.tigris.org/update_1.2.x

Then you are able to install subclipse 1.1.8 or newer.
After that, everything should continue to work fine :)

hope that helps,

Nico

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Thu Nov 9 18:49:56 2006

This is an archived mail posted to the TortoiseSVN Users mailing list.