[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: read access ok to repository. Write fails for unkow reason

From: <Craig.Schroeder_at_thomson.com>
Date: 2006-11-01 14:56:30 CET

Sebastien,

You're probably better off asking this on the svn list (users at svn dot
tigris dot org). Sounds like a configuration issue, but maybe you'll
get lucky and someone here has had the same problem.

--Craig

-----Original Message-----
From: Sebastien Leon [mailto:sleon@pointcarre.com]
Sent: Wednesday, November 01, 2006 7:10 AM
To: users@tortoisesvn.tigris.org
Subject: read access ok to repository. Write fails for unkow reason

Hi everybody,

I surfed users@tortoisesvn.tigris.org archive to solve my problem but
didn't found any answer.
Sorry to bother you if it is obvious... But, really it is very hard to
work now.

I use tortoise svn for one year now and everything was working fine.
First of all, it is a really great and complete tool and I would like to
thanks all people involved in it development. (any Linux port ? :-)

Yesterday, for unknow reason, for every Writing request I do (commit,
change author, change message) it fails and I receive an error message.
Read operations are still ok (update, show log...)

My configuration :
- tortoise svn 1.3.5 6804 32 bits (client side)

for server side, I think it is 1.2 or 1.3. (I have to ask to my ISP)

What I have done recently which should explain things go wrong :

- I updated tortoise from 1.3 to the new 1.4 (however, since that time,
I remove the new version, clean the registry, delete my working copy,
reboot several times :-), reinstall the "old"
TSVN, and co a new working copy)

- from a working copy which was checkouted with a Read only permission
account, I made some change and commit modification with my usual
account (which has R/W permission)

What's happen exactly now :

This is quite strange. I am not sure if the problem is server or client
side...
For any file I commit, here is the message : (same if I use svn.exe
command line)

Modified: E:\projects\Cameleon\trunk\Doc\TODO.txt
Sending content: E:\projects\Cameleon\trunk\Doc\TODO.txt
Error: Commit failed (details follow):
Error: PUT of
'/svn/!svn/wrk/57635708-75b7-534d-a439-6c3c1decda8a/projects/Cameleon/tr
unk/Doc/TODO.txt':
501 Method Not Implemented (https://pointcarre.typhon.org)

During commit process, an authentification dialog ask my login/password
(each time, which was never the case before)

My ISP told me that his log message contains a message saying that
multi-user is not implemented !? It has no clue either.

When I try to change author of message for any revision, I have another
message (message box) saying :

DAV request failed; it's possible that the repository's
pre-revprop-change hook either failed or is non-existent At least one
property change failed; repository is unchanged.

There is one strange thing :
when I reboot in Linux and commit from the SAME working copy (file
system is shared), it work fine (I use another login and I am afraid to
use my regular login because if it fails again I can't work anymore)

Any svn guru here which may explain this ?
Is it a server or client trouble ?

Thanks you for your help.

Please CC your answer to sleon at pointcarre dot com

Sebastien L.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Wed Nov 1 14:56:51 2006

This is an archived mail posted to the TortoiseSVN Users mailing list.