[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug with the 1.4 icons?

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: 2006-09-29 23:54:59 CEST

Simon Large wrote:

> Strange. I'm not aware that any other svn operation was locking the WC,
> although I don't remember the sequence of events that triggered it. I
> did leave it for a while and jumped around other folders to see if they
> were affected too (they weren't), before killing the cache. Strange too
> that killing the cache should fix it if the lock was held by another
> process. Sounds like the lock was held by the cache itself.

That would be strange, yes. But nothing is impossible.
Sometimes modifying a file inside the working copy also 'fixes' this
situation because then the cache starts crawling it again.

> Does the shell put a normal overlay even on the .svn folder if the cache
> cannot return status?

Yes, on *all* items in a folder which has an .svn folder in it. And it
also adds one to the .svn folder itself to indicate that the overlays
are not correct.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tortoisesvn.tigris.org
For additional commands, e-mail: users-help@tortoisesvn.tigris.org
Received on Fri Sep 29 23:55:07 2006

This is an archived mail posted to the TortoiseSVN Users mailing list.