[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Multiple user agent strings

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Tue, 02 Aug 2011 20:30:32 +0200

On 02.08.2011 19:37, Kevin Radke wrote:
> Nothing big, but when using Fiddler2 to debug some network traffic, I
> noticed TortoiseSVN
> (a 1.7.0-dev build 21719) is sending multiple user-agent strings. One
> includes the
> TortoiseSVN additional info the other doesn't. For example, using the
> repo-browser, the
> 6th and 7th requests are both "OPTIONS" requests, both fail with 401
> auth required, but
> each one has a different User-Agent string:
>
>
> User-Agent: SVN/1.7.0-dev/TortoiseSVN-1.6.99.21719 neon/0.29.6
> User-Agent: SVN/1.7.0-dev neon/0.29.6
>
>
> Not sure why it is sending duplicate requests with different user-agent strings.
>
> This is possibly an issue with neon, but for some reason, not all requests
> are getting the updated user agent value...
>
> The server machine is still 1.6.5, but I don't think that matters here.
>
> The user-agent strings vary during the conversation, this is just the
> first example.
>
> Kevin R.

Thanks for the report.
Fixed in r21766.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2808247
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2011-08-02 20:30:55 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.