[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: build problem branch 1.6.11/1.6.10

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 13 Oct 2010 18:25:48 +0200

On 13.10.2010 10:28, Christoph Bernhofer wrote:
> Hi
>
> I am not able to build the branches 1.6.10 or 1.6.11, getting the same
> error for all two branches in ToirtoiseProc, here for 1.6.11:
>
> ...
>
> Rebuild started: Project: TortoiseProc, Configuration: Release|Win32
>
> ... output
>
> Compiling...
>
> stdafx.cpp
>
> Compiling...
>
> TortoiseProc.cpp
>
> URLDlg.cpp
>
> SVNProgressDlg.cpp
>
> c:\BUILD\older_versions\tortoisesvn-1.6.11\src\Utils\MiscUI\IconMenu.h(27)
> : error C2011: '_BP_BUFFERFORMAT' : 'enum' type redefinition
> ....
>
> Do you have any idea what was going wrong here?

Yes: you're using the wrong windows SDK.
As per the instructions in the build.txt file, you have to use the
"Microsoft SDK for Windows Vista (February 2007 Update)" for that build.
Newer SDKs might work, but aren't tested.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2671296
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-10-13 18:26:01 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.