[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SubWCRev -m and -e switches works in wrong way

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Mon, 11 Oct 2010 21:33:13 +0200

On 09.10.2010 17:08, Oto BREZINA wrote:
> What I did:
> using: TortoiseSVN 1.6.99, Build 20162 - 32 Bit -dev, 2010/09/20 21:06:28
> I run command: "c:\program files\TortoiseSVN\bin"\SubWCRev.exe . -me
> on checked out WC. There may be some non-versioned files like
> version.tmpl used for command in script.
>
> What I get:
> Working copy contains mixed revisions -1:700! Even I don't have any
> local changes.
>
> What I expect:
> I expect revision number like without -m switch
>
> Workaround:
> Don't use -me switch, however this leads to build even in cases where
> there is real mix of revision because of some error.

Fixed in r20286

>
> Note: without -m switch I get good result with wrong warning
> Note: -e switch works too in unexpected way is checks external from
> other repositories making revision number highest from all.

Fixed in r20287.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2670186
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-10-11 21:33:28 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.