[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.6.8 won't retrieve new / changed files from the repository

From: Walter K <goodvin_at_netscape.net>
Date: Thu, 13 May 2010 19:08:43 -0700 (PDT)

Hi,

This is a bug report. I've had a situation where new files are not being retrieved from the repository. I have the same repository setup twice on the local machine (don't ask why). File structure is like this:

ProjectName
  Proj_v2+Lib
    SubProject
  Trunk
    SubProject

"ProjectName" is not under SVN control, only the other its children are. I was working in "Proj_v2+Lib\SubProject" folder: renamed a couple of files, updated another dozen of so, and committed my work back into SVN.

When I updated "Trunk" project, it properly deleted renamed files, but never retrieved newly added, i.e. renamed, files. After update was completed, it showed as if everything was up to date. I had to delete "SubProject" folder and re-get it from the repository in order to have my new files.

Also, while still missing new files in my "Trunk" folder, I changed case (renamed) a few files in the repository browser. Upon update to each of the project folders, "Proj_v2+Lib" had the renamed files, but "Trunk" removed the old files without receiving the new files.

This is on Windows XP SP3, TSVN 1.6.8.

Thanks!

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=757&dsMessageId=2608846

To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2010-05-14 05:45:17 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.