[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Patch: reducing amount of duplicate code

From: Stefan Fuhrmann <stefanfuhrmann_at_alice-dsl.de>
Date: Fri, 4 Sep 2009 14:52:00 +0200

Dmitry <wipedout_at_yandex.ru> wrote:

> Here's more of the same - rewriting long method, eliminating duplicate
code for calling CreateProcess().

Committed with minor fixes in r17100-1.

> Also in ContextMenu.cpp once in a while there's a line
> svnCmd += _T("\"";)
> which I suppose was meant to be
> svnCmd += _T("\"");
> Fixed it but unsure if it was the right idea.

No that's fine. Macro expansion will remove the parenthesis
so, technically, both should be equivalent. IMHO, the second
form is to be preferred, though. Fixed further occurrences
in r17114.

-- Stefan^2.


To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-09-04 14:52:07 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.