[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Patch: reducing amount of duplicate code

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Tue, 01 Sep 2009 19:48:26 +0200

On 01.09.2009 07:14, Dmitry wrote:
> Hey.
> Here's a patch for reducing code duplication. Not tested - needs
> review.
> Also (prior to the patch) in OnCaretLeft() and OnCaretRight() first
> follows EnsureCaretVisible(), then UpdateCaret(), and in OnCaretUp()
> and OnCaretDown() the above two calls are in reverse order. Is this
> reverse order ever needed? If not, onCaretWordLeftRight() method
> could be renamed into onCaretMove() and further reused.

Thanks a lot for your patch. Committed in r17088 including your
suggestions aboout onCaretMove().

One minor nitpick: please use method names which start with a capital
letter to keep them consistent with all other method names.


   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net
To unsubscribe from this discussion, e-mail: [dev-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2009-09-01 19:48:40 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.