[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Context menu icon coloring issue

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Thu, 02 Oct 2008 21:36:17 +0200

Robert Dailey wrote:
> On Thu, Oct 2, 2008 at 11:25 AM, Stefan Küng <tortoisesvn_at_gmail.com
> <mailto:tortoisesvn_at_gmail.com>> wrote:
>
> Robert Dailey wrote:
> > In the latest nightly build, I noticed that icons were added to the
> > Repo Browser dialog. When hovering your cursor over these context menu
> > items, a blue selection background appears over the respective context
> > menu item. This causes the transparent background of that icon to be
> > black and the actual colored (opaque) parts of the icon to become
> > inverted (Green becomes teal, etc).
>
> Let me guess: you're using WindowBlinds?
>
>
> LOL!
>
> Good guess, but I haven't been using that POS for a long time ;)
>
> This is good ol' windows acting up here it seems.

Hmm - I can reproduce this on my XP virtual machine. Problem is though:
without ownerdrawing the menu (and the icons) I don't see how we could
prevent this.
And ownerdrawing is bad, because then blind people who use sw which
reads them the menus out loud can't use them: ownerdrawn means no text
for those apps to read.

Stefan

-- 
       ___
  oo  // \\      "De Chelonian Mobile"
 (_,\/ \_/ \     TortoiseSVN
   \ \_/_\_/>    The coolest Interface to (Sub)Version Control
   /_/   \_\     http://tortoisesvn.net

Received on 2008-10-02 21:36:35 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.