[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bug (1.5): 'ignore' icon showing up where it shouldn't...

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Fri, 06 Jun 2008 22:54:16 +0200

Robert Dailey wrote:
> On Fri, Jun 6, 2008 at 10:59 AM, Stefan Küng <tortoisesvn_at_gmail.com
> <mailto:tortoisesvn_at_gmail.com>> wrote:
>
> Robert Dailey wrote:
>
> Nope, I don't have it installed. In fact, this is a fresh
> install of Windows XP as of yesterday. I saw this happen on
> Vista too I think (that was my OS before I reinstalled)
>
>
> Can you please tell me all the settings from
> * Settings->Icon Overlays
> * Settings->General->Global ignore pattern
>
>
> One extra thing before I answer your questions:
>
> I notice that this only happens when I have 1 explorer window open
> showing a folder inside of my working copy that has ignore overlays in
> it. When I open a 2nd explorer window showing C:\, most of the folders
> have svn:ignore overlays on them.
>
> Now to answer your questions:
> Items that are checked in "Settings > Icon Overlays" (Items not listed
> here are unchecked):
> * Show overlay for ignored items
> * Show overlay for unversioned items
> * Fixed drives
> * Show excluded folders as normal
>
> "Status cache" is set to "Default"
>
> Settings > General > "Global ignore pattern" is empty

I really hate such problems: they don't show up in a debug build and not
on my workstation but only in a virtual machine. That always causes
major problems to reproduce and fix this.

Anyway: I think I got the problem fixed in r13156. Can you please grab
the next nightly build and check whether this is really fixed?

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.net

Received on 2008-06-06 22:54:37 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.