[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Missing columns in explorer details view on win2k

From: Martin von Gagern <Martin.vGagern_at_gmx.net>
Date: Thu, 03 Apr 2008 16:02:41 +0200

Jean-Marc van Leerdam wrote:
> What folder display options are you using? If you do not have the 'use
> these settings on all folders' then you may have to add the special
> columns on each new folder separately...

I've got a German Windows, so let's see how things look here. I'll try
to give a rough translation, but I guess most items will be named
differently in an English version of Windows.

Application Explorer
Menu Extras Extras
Menu Item Ordneroptionen... Folder settings...
Tab Ansicht View
Tree Erweiterte Einstellungen Extended settings
Tree Item Ansichtoptionen für jeden Save view options
              Ordner speichern for each folder

This one is disabled. Therefore I'd assume all folders should use common
display settings, and there should be no folder-specific settings.

Tab Ansicht View
Group Ordneransicht Folder view
Button Alle Ordner zurücksetzen Reset all folders

Pressing that button did not solve the issue.

Tab Ansicht View
Group Ordneransicht Folder view
Button Wie aktueller Ordner Like current folder

This seems to most closely match this "use these settings on all
folders" you have mentioned. Pressing this button in a directory
correctly displaying the SVN columns still doesn't solve the issue.

I finally found out how to add columns, i.e. right-click on the header
bar of the details view. With this I can in fact add these columns.
However, doing so for every folder is tedious at best, and
counter-intuitive to boot.

Perhaps this whole thing might actually be a problem of Win2k, I don't
know. I have no clue where Windows does save its folder-specific
settings, apart from this desktop.ini for icon positions and such. There
is no such desktop.ini in the folder in question, and if there were,
that wouldn't explain why renaming it changes anything. So I assume
there is some kind of central storage. Coudln't find a likely entry in
the registry. Any other ideas? If someone knows, I might try to have a
look what the settings are actually like, to figure out where all this
comes from.

Greetings,
  Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: dev-help_at_tortoisesvn.tigris.org
Received on 2008-04-03 16:12:54 CEST

This is an archived mail posted to the TortoiseSVN Dev mailing list.