[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: TortoiseSVN 1.5.0-alpha1 - compatibility

From: Ulf Zibis <Ulf.Zibis_at_CoSoCo.de>
Date: Sat, 22 Mar 2008 21:17:28 +0100

Hi Stefan,

thanks for your answer.

To make it more clear. I have installed:

Subversion 1.4.6

TortoiseSVN 1.4.99, Build 11652 - 32 Bit -dev, 2007/12/21 23:09:09
Subversion 1.5.0, -dev
apr 1.2.11
apr-utils 1.2.10
berkeley db 4.4.20
neon 0.27.2
OpenSSL 0.9.8g 19 Oct 2007
zlib 1.2.3

My Netbeans IDE uses the svn.exe AFAIK which is 1.4.6. It works fine.
Netbeans FAQ says: IDE supports only working copies created by
Subversion clients 1.3.x and 1.4.0
This makes me wondering, as I've installed TortoiseSVN 1.4.99.

Now I have the question, if I it is a good idea to update my TSVN to
1.5.0-alpha1
I just noticed the "This version will upgrade your working copies
automatically to the new version." since you published TortoiseSVN
1.5.0-alpha1.
Is this warning also true, if I only have Subversion 1.4.6 installed (in
contrast to Subversion 1.5.0)?

-Ulf

Am 22.03.2008 15:56, Stefan KŁng schrieb:
> Ulf Zibis wrote:
>> Hi,
>>
>> in the compatibility concerns I read:
>>
>> "This version will upgrade your working copies automatically to the
>> new version. If you have other Subversion clients you use, do /not/
>> install this release unless you have 1.5.x versions of those clients
>> too."
>>
>> As I'm using nightly builds since long time, to benefit from the new
>> features, parallel to the client of the NetBeans IDE 6.01 I ask:
>> Do you know if NetBeans IDE 6.01's svn client is compatible with the
>> new version of the working copies?
>
> If you're using the nightly builds from the /latest folder, then you
> already have the new working copy format.
> If however you're using the nightly builds from the 1.4.x branch, then
> I doubt that your IDE's svn client would be compatible.
>
> Stefan
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe_at_tortoisesvn.tigris.org
For additional commands, e-mail: dev-help_at_tortoisesvn.tigris.org
Received on 2008-03-22 21:18:03 CET

This is an archived mail posted to the TortoiseSVN Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.