[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Apply Patch always shows Save As... dialog in 1.4.4

From: Scott Blum <scottb_at_google.com>
Date: Wed, 23 Jan 2008 21:57:10 -0500

Hi,

I was wondering if this issue has been addressed. I searched the Issue
Tracker for "patch" and none of the issues that I found matched this bug
report.

Thanks,
Scott

On Aug 8, 2007 11:10 PM, Scott Blum <scottb_at_google.com> wrote:

> Verified that this problem does not occur in
>
> TortoiseSVN 1.4.3, Build 8645 - 32 Bit , 2007/02/04 09:40:57
>
>
> On 8/6/07, Scott Blum < scottb_at_google.com> wrote:
> >
> > Hi,
> >
> > I recently upgraded to TortoiseSVN 1.4.4 - 9706. In the version I had
> > before (unsure which version, 1.4.x), I could create a patch file that
> > included new files in the Added state. When applying the patchfile to a
> > clean repository at the same revision, these new files would be created at
> > exactly the right place in the working copy, mirroring the file structure
> > from which the patch was created.
> >
> > However, this no longer works in 1.4.4. Now when I try to apply the
> > patch file, I get a "Save As.." dialog for all new files. This would be
> > annoying if it were a simple confirmation, but it's worse that that. The
> > Save As... dialog has NO information about the file I need to save... it's
> > browsed to my Desktop and doesn't even have the right filename filled in.
> >
> > Is there any workaround or setting I can adjust? Apply patch is now
> > unusable for me and I'm about to have to reinstall an older version of TSVN.
> >
> > Thanks,
> > Scott
> >
> >
>
Received on 2008-01-24 07:16:07 CET

This is an archived mail posted to the TortoiseSVN Dev mailing list.